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This SOP covers how to publish PDF’s and IETM’s using Arbortext Editor with
Styler. Users of this document should include technical writers and publishers who are
familiar with the standards listed in the following sections.
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Arbortext Publishing Requirements (for PDF’s)

SOFTWARE

Arbortext Editor 6.0 , Datecode: F000 (PTC)

Arbortext Styler (PTC)

Arbortext Publishing Engine (PTC)

STANDARDS

MIL-STD-40051-2 - Preparation of Digital Technical
Information For Page-Based Technical Manuals (TMs)

- Appendix A Matrices

MIL-STD-2361C / MIL-STD-2361D — Digital
Publications Development, Production XML DTD
reference

FILES

XML documents — Technical Manual .xml document , production.dtd (for
the production.dtd file, go to the LOGSA website and access Publications ->
MIL-STD-40051 from the dropdown menu)

Stylesheet — 40051C 3 26.fos ( James Kay - james.r.kay4.ctr@mail.mil )
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PDF publish — xsl-fo-main-vl 8.xsl
OR
xsl-fo-main-vl 9.xsl (latest)
(go to the LOGSA website and access Publications -> MIL-STD-40051)

Arbortext Publishing Requirements (for IETM’s)

SOFTWARE
Arbortext Editor 6.0 , Datecode: F000 (PTC)

Arbortext Styler (PTC)

Arbortext Publishing Engine (PTC)

Creo View (for viewing animations)

Creo Illustrate (for creating animations)

STANDARDS

MIL-STD-40051-1 - Preparation of Digital Technical Information
For Interactive Electronic Technical Manuals (IETMs)

MIL-STD-2361C / MIL-STD-2361D — Digital Publications Development,
Production XML DTD reference

FILES

XML documents — Technical Manual .xml document , production.dtd
(for the production.dtd file, go to the LOGSA website and access
Publications -> MIL-STD-40051 from the dropdown menu)
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Stylesheet — Standard DITA Stylesheet (production.style) (PTC)

Publishing SOP (PDF)

1. Verify that your local administrator has installed and configured your Arbortext
Editor with Styler environment (connection to Windchill, XML bursting files, etc.)

2. Ensure Context Rules are turned on. This enables Arbortext to alert you when you
attempt to insert an XML tag in an incorrect location according to the DTD file.

e v
L. Arbortext Editor - HMI M-2
File Edit Find View Insert Object Table |Tools| Styler Format Window Help

DEESGRBRAY| LBRB| 9 v ™% Speling.. F7
TreER(B| Qv B [H hesauns. Shift+F7
B e U U
=i Y EZ0EE Word Count Ctrl+Shift+G
figure v grophic v | B Z U |i= =]
== & production - Set the attribute mac2ivi 5 Change Tracking 4
& EI & framed.manual put the proper &
| £ functionhierarchy lementation of 2
. &= framed.frnt ContextRnies
OE & revisionsummary IDs and ID References...
L= title E
) para -~ HCP ESD Program f ave Application..
~El ® wpno Preferences...
= desc — .

3. When you wish to verify that all XML tags are present in the Technical Manual and
they appear in the proper context, use the Check Completeness button. Arbortext
will alert you to any missing information.
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File Edit Find View Insert Object Tab

Elélﬁ VIid BB o~

4. Open Arbortext Editor with Styler. Open the technical manual XML template file

provided to you based on the required technical manual matrix
(MIL-STD-40051-2), then click OK.

5. A dialog box should appear. Select Browse for Schema/DTD. Browse to the
production.dtd file and click OK. The document should open in Arbortext.

Choose

@Browse for Schema/DTD:
Open in free-form mode without Schema/DTD

Open as text

6. Click Format -> Select Stylesheets.... Under “Print/PDF” in the “Selected for”
column in the dialog box, click Modify.... In the new dialog box, click Add... and
browse to the production.fos file. Click Open..., click Add Association, click
Select, click OK, and click Close.
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7 — —— —_—
Select Stylesheets I n M
Currently selected stylesheets:
Selected for Title

Path/URL  Association

[ »

Editor/Default 400518 FOSI

C:\Users\... Yes =
HTML File [Default] None
HTML Help [Neone]
| | Web [None]

-
|

| set to Default| [ Modify... |

L | Gose [[ tep |

7. Following the instructions in the MIL-STD-40051-2 and MIL-STD-2361C / MIL-

STD-2361D standards, prepare the XML Technical Manual. (Animations will be
unavailable when publishing to PDF’s).
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Set the attribute mac2ivi = 1 to output the proper 2 level maintenance TM title.
Refer to LOGSA guidance on implementation of 2 level maintenance TM Titles.

title
HCPESD para
desc

tmno

. TECHNICAL MANUAL
N FOR

name|

. AUTHOR'S NOTE -The elements in the notices may be either system generated or entered manually with element content. Ifitis

= decided to use generated models, ALL notices will be generated. If manual entry is desired, all MUST be manually entered.

. Reference AR 25-30 for inclusion of the Disclsoure statement that must accompany distribution statements B, C, D, E, F or X when

used with munitions. If applicable, add the tag discl before the disttag

Distribution D Statement shall be in compliance with AR 25-40 and DoD Directive 5230.24 subj: Distribution Statements on Technical

- Documents.

— r DISTRIBUTION STATEMENT D — Distribution authorized to Department of Defense and U.S. DoD
contractors only Administrative or Operational Use. This determination was made on . Other requests for this document must be
referred to .

servnomen date

CHAPTER 1—

CHAPTER 2 — GENERAL INFORMATION, TROUBLESHOOTING PROCEDURES
- (ARMY, NAVY, AIR FORCE, MARINES ONLY)
= 0000 00

CHAPTER 3 — GENERAL INFORMATION, MAINTENANCE INSTRUCTIONS

CHAPTER 5 - SUPPORTING INFORMATION
contents

8. When ready to publish, click File -> Publish -> PDF File...

9. In the Stylesheet dialog box, browse to the xsl-fo-main-v1_8.xsl (or xsl-fo-main-
vl _9.xsl) file.

10.Click Publish. You can now save the PDF either locally or in Windchill.
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Publishing SOP (IETM)

NOTE: This SOP assumes the use of the DITA format for making IETM’s. If you are
following MIL-STD-40051, you will need an XML template file for creating an IETM
depending on its content. Refer to Table A-XVIII in the MIL-STD-40051-1B PDF
document for a list of possible Technical Manual configurations. You will then need to
contact the Technical Publications group on-site to request a copy of these templates.

NOTE: Before beginning an HTML IETM in Arbortext and Windchill, make sure there
isn't already a repository of text and graphics files somewhere on the server that can be
used in your IETM. Linking to these can save time, server space and may cut down on
duplicates.

1. Ensure your local administrator has installed and configured your Arbortext Editor
and Styler environment (connection to Windchill, XML bursting files, etc.)

2. Open Arbortext Editor with Styler. Select File -> New, then select the DITA
Technical Content folder in the Category section and select DITA BookMap, then
click OK.
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P
New Document @
Category: Type:
(2] Service Manual Application
----- () DITA Technical Content (2 pITA Map
...[]) DITA Learning and Training () DITA Concept
3 DITA Glossary
i..”] DocBook
) HTML [3 DITA Reference
""" [2 DITA Task
""" (3 Other [ DITA Topic
[2) DITA Ditabase
[2) DITA Key Definition Map
@ Template () Sample [ OK ] [ Cancel ] [ Help

3. Click View -> Document Map to change the look of the interface in order to make
adding content to the bookmap easier.

File Edit Find
D &
R

[No element]

EIEI & bookm

_View| Insert Object Table Tools Styler Format Window Help

Collapse Element Content k )'6 %6 v| izzs]
Collapse bookmap Content 1E v| B s A .
IE Collapse/Expand Divisions...
Edit View Alt+Ctrl+N
v | Document Map Alt+Ctrl+0 I
Column View Alt+Ctrl+L
Resource Manager...
Toolbars »
Font Size 4

4. Place the cursor after frontmatter, hit the enter button and click booklists. Then
place the cursor after booklists, hit the enter button and click toe. This will provide
a Table-of-Contents frame for the published IETM. The toc will consist of links to
navigate throughout the [ETM.
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=-{Z] & bookmap
-] booktitle - Main Book Title
-] frontmatter
. ..[Z] booklists booklists split

* frontmatter

..... [=] backmatter abbrevlist

' bookmap bibliolist

booklist
figurelist
glossarylist
indexlist

tablelist

toc

trademarklist

5. Place the cursor before backmatter, hit enter and click chapter. Do this for as
many chapters as will appear in the published IETM.

6. If the chapter consists of only one section, you can place the cursor in the chapter,
hit enter and click topicref.

If the chapter consists of multiple sections, you will need to create a map. Select
File -> New, then select DITA map and click OK. Place the cursor in front of the
last map tag, hit enter and click topicref. Do this as many times as necessary until
all chapter sections are inserted in the map. Now return to the bookmap, place the
cursor after the appropriate chapter, hit enter and click mapref. Then hit Ctrl -> d.
In the href field in the dialog box, browse to the map that you created previously
and click modify, then click OK.

7. Select File -> New, then select either DITA topic, DITA task, or DITA concept
depending on the content to appear in the chapter and click OK.
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8. Add content to the topic/task/concept. To see what content is appropriate for each

tag, select Help -> Help Center and type in the tag name in the search box. To add
more tags, place the cursor where you want the tag to be and hit the enter button.
The tags you will need most often include the <note> and <image> tags.

note S | O | S|
Help Center
Arbortext
e e = 9 -3
note Search | advanced £ * = | = R > = | @
= 3 . | % =
=l o Ik 3.1.1.2.24 note
Sorted by: Relevance -
1 - 500 of total 2306 search results - A <pofe> element contains information, differentiated from the main text, which expands on or calls =
— =1 attention to a particular point
A <note> element contains information,
differentiated from the main text, which Tip: Variant types of pote (tip. caution, fianger, restriction, etc.) can be indicated
expands on or calls attention to a through values selected on the type attribute. This pote is typed as a "tip."”
particular point.
Notes and limitations Contains
The following notes and limitations apply
to the Arbortext Editor and the Arbortext MBEE: These models represent only the default document types distributed by
Publishing Engine implementations of OASIS. Actual content models will differ with each new document type.
events: Be aware that DOM mutation
events trigger ... Doctype Content model
Notes and Limitations topic (base), map (text data or dl or fig or imagemap or image or lines or lg or object or ol or
Be aware of the following issues when (base), classifyMap, | p or pre or simpletable or sl or table or ul or boolean or cite or keyword or
using merged data with Arbortext Editor: subjectScheme, ph or b or i or sup or sub or tt or u or g or term or tm or xref or state or data
Because using merged data requires the learningBookmap, | or data-about or foreign or unknown or draft-comment or fn or indextermref
use of namespaced markup, merged data learni or indexterm or required-cleanup) (any number)
cannot be used ...
Translation Note Dialog Box topic (technical ( text data or dl or oarm: or fig or swﬂaxdlagr‘an‘ or imagemap or image or
This dialog box displays when you select content), map Imesla'r Lglnr ob; Iecl or oT orp ‘or pre olr codeblock or mvsrgblcéck or screen or
the Transiation » Add Note menu option ! con simpletable or sl or table ?;i or boolean or cite or keyword or sowlhame'or
(or the Translation » Edit Note option if concept, ditabase, ggllon or oarmnarge or cmdname gr rrgsqnum u}r ,arlf\lame )c:r ,un}n e:rm or
a translation note already exists) in ... glossary, glossentry, b orior sup or sub or tt or u or codeph or synph or filepath or msgph or
glossgroup, systemoutput or userinput or menucascade or uicontrol or g or term or
DLM usage notes o reference, task, abbreviated-form or tm or xref or state or data or data-about or foreign or
Be aware of the following items when bookmap unknown or draft-comment or fn or indextermref or indexterm or required-
working with DLM . In certain rare cleanup) (any number)
situations, links and targets may be ceanue
reported as present even though they machineryTask ( text data or dl or fig or imagemap or image or lines or Ig or object or ol or
had been previously deleted fr ... D or pre or screen or simpletable or sl or table or ul or boolean or cite or
Arbortext® Publishing Engine™ Rel 1 keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade N
o T ar uicantral ar a or term or tm ar xref or state ar data or data-about or

9. To add animations, add the animation file itself as a graphic. Once done, you need
to add a hyperlink to be clicked to activate the animation. Place the cursor in the
location where you want to insert the link or select the text that you want to be the
source of the link. If the Resource Manager is not open, choose
Insert -> Link/Xref or click the ¥toolbar button.

On the Link/Xref tab, navigate to the image tag for the animation to which you want
to link in the browser and select it. If you want to initiate an action, either double-

click on the B choices in the browser, or use the Menu button or the Resource
Manager popup menu to select Insert View Link (note that the Insert Animation
Link and Insert View Link choices are only available if the selected graphic contains
animations or views.) Use the dialog box to define the action associated with the
link (you will need to click in the model-space window in order for the Animation
checkbox to appear and select it), then click Insert.

The dialog box closes and the link is inserted into your document. If you double-
click on the link, you can view the associated action in the target graphic.
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10. Once the topics/tasks/concepts are finished, add them to the maps and bookmap as

necessary. Place the cursor after the appropriate chapter and hit Ctrl -=> d. In the
href field in the dialog box, browse to the topic/task/concept and click modify, then
click OK.

11. (If you’re not using Windchill, proceed to step 12 for publishing)
To check-in the bookmap to Windchill, select Object -> Connect, then enter your
username and password and click Next >. Select the proper workspace from the
Workspace dropdown menu or create a new one and click Finish.

g B
Connect L—J&
Connect to: PTC Server -
Server: Windchill 10 -
User Name: user
Password: TTYTITYTYY
| Work Offiine
Next > ] { Cancel ] [ Help
L\

If the bookmap has not been checked-into Windchill previously, select File -> Save
As Server Object. In the dialog box, ensure the “Keep objects checked out” box is
un-checked and the “Use location rules for child objects” box is checked. Also
ensure the path in the Folder field is directed to go to the same location as the
bursting configuration files dictate, or the chapters associated with the bookmap will
not be burst into the correct folders in Windchill. Click OK. The bookmap and all
associated files should be checked-into Windchill in their appropriate locations.

If the bookmap has already been checked-into Windchill previously, select

Object -> Check In Object. Ensure the “Check in all child objects” box is checked
and click OK.
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Save As Properties (2| & |
Name: V2.6 RHINO and V3.0 rhino
Folder: /Products/Rhino 3.0 @
[ Keep objects checked out:

[¥] Use location rules for child objects

Baseline Name:

Baseline Folder:

oK ] [ Cancel ] [ Help ]

NOTE: If you are working with documents that are in Windchill, don’t forget to hit
"Refresh" in the Resource Manager when you see the asterisk (*) appear on the Refresh

button. Automatic pinging between Arbortext and Windchill is not on by default to cut
down on traffic to/from the server.

12. To publish the IETM, select File -> Publish -> For Web..., then click Publish.
The url address at the top of the browser window containing the published IETM
should show the location where the IETM files were published to. (Don’t publish
Technical Manuals using the “Publish to HTML” option unless you need to see
animations and publishing an IETM isn't necessary.)
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| File| Edit Find View Insert Object Table Tools Styler Format Window Help

O New.. Ctrl+N Cx v| A )6 ;6 v ‘ iz 6 o+
= Open.. Ctrl+O P | e @‘ ] v| B =
Close Ctrl+W |]‘A‘&~
Import » EE| « » l - q
ﬂ Save Ctrl+S o outputthe proper * B « - + 1
Save As.. F12 [T settne
Save as SGML... - C Refert
Save as HTML... B i title
Save All Ctrl+Shift+S ll| HCPES
: desc
Revert to Saved
Print Preview... Alt+Ctrl+P 5
& Print... Ctrl+P .
o~
| Publish » For Web...
For Digital Media Publisher...
Page Setup...

Print Editor View...

HTML File...
.\24_testxml

1
PDF File...
2..\23_testxml
RTF File...
3 .. \siteprefs.xml
4 . \userprefsxml Using Rule...
w\si fs.xml
5 .. \siteprefs.xm Using XSL...
6 4.1.1 Mechanical Installation.dita
Docum
7 ..\production.dtd T D - Distribution w  reasor
8 C:\..\Desktop\xml_test.xml . contrac
referrec
Exit .~ servnc

NOTE: When adding images, animation files or other external objects to an IETM or
PDF, do not move them from their present location while in the process of creating the
IETM or PDF, as doing so could cause the images to be lost from the published product.
If you have relocated various items, remove them from the IETM or PDF and add them
again from their new location.

Additional Resources

* Refer to the Reference Documentation folder for the Arbortext Editor manual,

installation guides and other documents.
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* Sometimes linking between 2 or more IETM’s is necessary to convey more
information. Refer to the Linking between IETMs document for a walkthrough of

this process.

e Refer to the Standards folder for documentation on the various standards used for
authoring [ETM’s.

Tag Errors (DO NOT USE when publishing)

* <para0>
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